Back to overview
Degraded

SEVERE WEATHER - HEAVY BLIZZARD

Mar 8, 2023 at 5:31pm UTC
Affected services
TDT VM 1

Resolved
Mar 9, 2023 at 7:05am UTC

Weather has cleared up

Created
Mar 8, 2023 at 5:31pm UTC

SEVERE WEATHER IMPACTS TDT VOOPLV SECTOR DUE TO A HEAVY BLIZZARD IN THE AREA IT CAUSES POWER ISSUES TO THE AREA